Page 2 of 2 FirstFirst 12
Results 11 to 12 of 12

Thread: New to MAP ecu & could dop with a few pointers pls

  1. #11


    Quote Originally Posted by MAP-ECU Man View Post
    It's always possible there is a problem with the voltage regulator, but we have never seen it before. I am not so much worried about your solder/heatshrink as the OEM ECU pin. We have seen many high resistance pins on the OEM ECU connector. Check for a voltage between the MAPECU ground and chassis. It should be zero.

    Don't worry too much about a video, just a screen shot. I assume you know how to grab a screen shot to the clipboard using the PrintScreen keyboard key. You can then paste into Windows Paint.exe and crop the image. Save it as a JPEG and you can upload to the forum.

    Also, also check the "MAF 0" value under ECU Configuration is 2170 to simulate the a MAP sensor at sea level.
    Not the best news I am afraid.

    I checked the earth out and all was good, checked it out between the mapecu and the oem ecu, I have also checked it out between -ve of the battery and car chassis, just for good measure I added a earth between a chassis earth point and the Mapecu. With the oem MAP sensor plugged up I have exactly 5v between the 5v pin of the stock MAP sensor and battery -ve terminal, suggesting all is well in terms of grounding.

    I then loaded MAPCAL and that took a couple of attempts to load the info from the ecu correctly, with a couple of errors showing in the status bar on the other occasions, "connection timeout" I think was one after a long period of reading from ecu.

    Ran the engine and it was still the same very lumpy, almost hunting and the engine management light on.

    Stopped engine to check things and was going to then try a screen grab on the next try and it said ecu offline. From this point onwards I was unable to connect to the ecu, it as getting late and I gave up for the night. When I tried to connect I was getting either connection timeout, or it was hanging whilst reading ecu, or on a couple of occasions I got a "stack error" dialogue box up on the PC and then mapcal closed on its own.

    Will have another play this weekend, but have started to think I bought a flaky mapecu and its really starting to die now.

    The reading problems reading from the ecu to the laptop sort of smack of a serial connection fault, but nothing has changed since last time I tried it, same adaptor and PC not been used for anything else since.

    Thanks in advance.


  2. #12


    Those errors sound very much like the USB to serial adaptor you are using is the problem. We have seen many dodgy ones cause problems like this so the MAPECU never gets a good load.

    We recommend the ones from FTDI ( as we use their chips in MAPECU3.

    The best way to check you have a good fuel table loaded is to measure the voltage on the Green MAF wire.
    MAP-ECU Support

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts